请选择 进入手机版 | 继续访问电脑版
切换皮肤
一、交换机的端口类型
局域网为了隔离广播必须划分VLAN,了解VLAN的划分与配置,必须先熟悉交换机的端口类型,交换机的端口类型主要有Access、Trunk、Hybrid三类,这里我们主要介绍前两种类型的端口:
Access(接入)端口:接收、发送不带标签的报文,一般与pc、server相连时使用,只属于1个VLAN;
Trunk(中继)端口:接收、发送带标签的报文,一般用于交换机级联端口传递多组vlan信息时使用,可属于多个VLAN;
这两种类型的端口主要应用拓扑如图所示,图中SW1和SW2的1/2/3/4端口都设置为Access类型,分别属于VLAN10/VLAN20/VLAN30/VLAN40,而交换机的5端口设置为Trunk类型,能同时通过VLAN10/VLAN20/VLAN30/VLAN40。
?url=http%3A%2F%2Fdingyue.ws.126.net%2F2020%2F0508%2F1d6e8521p00qa08dp000kc000hz007vc.jpg
[size=0.28]打开网易新闻 查看更多图片 [size=0.19]


二、交换机的VLAN配置
接下来我们用华为模拟器ENSP来完成以上拓扑的配置,首先搭建拓扑图如下所示。
?url=http%3A%2F%2Fdingyue.ws.126.net%2F2020%2F0508%2Fa707c999p00qa08dp0019c000lc00b1c.jpg
思路:与PC端相连的端口配置A口,交换机之间的端口配置T口。
首先我们进入SW1的配置。
进入系统视图后,首先在SW1中建立4个VLAN,命令如下
[SW1]vlan batch 10 20 30 40/建立4个VLAN,分别对应四个端口
然后进入交换机的接口E0/0/1
[SW1]interface Ethernet0/0/1
[SW1-Ethernet0/0/1]port link-type access/设置端口为Access
[SW1-Ethernet0/0/1]port default vlan 10/将端口归属为VLAN10
#
[SW1]interface Ethernet0/0/2
[SW1-Ethernet0/0/2]port link-type access/设置端口为Access
[SW1-Ethernet0/0/2]port default vlan 20/将端口归属为VLAN20
#
[SW1]interface Ethernet0/0/3
[SW1-Ethernet0/0/3]port link-type access/设置端口为Access
[SW1-Ethernet0/0/3]port default vlan 30/将端口归属为VLAN30
#
[SW1]interface Ethernet0/0/4
[SW1-Ethernet0/0/4]port link-type access/设置端口为Access
[SW1-Ethernet0/0/4]port default vlan 40/将端口归属为VLAN40
#
[SW1]interface Ethernet0/0/5
[SW1-Ethernet0/0/5]port link-type trunk/设置端口为Trunk
[SW1-Ethernet0/0/5]port trunk allow-pass vlan 10 20 30 40/让端口5通过VLAN10 20 30 40
用同样的方法,完成SW2的配置。
[SW2]vlan batch 10 20 30 40
然后进入交换机的接口E0/0/1
[SW2]interface Ethernet0/0/1
[SW2-Ethernet0/0/1]port link-type access/设置端口为Access
[SW2-Ethernet0/0/1]port default vlan 10/将端口归属为VLAN10
#
[SW2]interface Ethernet0/0/2
[SW2-Ethernet0/0/2]port link-type access/设置端口为Access
[SW2-Ethernet0/0/2]port default vlan 20/将端口归属为VLAN20
#
[SW2]interface Ethernet0/0/3
[SW2-Ethernet0/0/3]port link-type access/设置端口为Access
[SW2-Ethernet0/0/3]port default vlan 30/将端口归属为VLAN30
#
[SW2]interface Ethernet0/0/4
[SW2-Ethernet0/0/4]port link-type access/设置端口为Access
[SW2-Ethernet0/0/4]port default vlan 40/将端口归属为VLAN40
#
[SW2]interface Ethernet0/0/5
[SW2-Ethernet0/0/5]port link-type trunk/设置端口为Trunk
[SW1-Ethernet0/0/5]port trunk allow-pass vlan 10 20 30 40/让端口5通过VLAN10 20 30 40
接下来配置PC1-PC8的IP地址,这里只给出PC1的地址截图。
?url=http%3A%2F%2Fdingyue.ws.126.net%2F2020%2F0508%2Fca1b0f5ep00qa08dp000mc000lk00ejc.jpg
配置完后,我们进行VLAN10的通信测试(只测试PC1与PC5)
?url=http%3A%2F%2Fdingyue.ws.126.net%2F2020%2F0508%2F67cd32d3p00qa08dp000kc000gr00bkc.jpg
至此,可以看到PC1和PC5能互相通信,交换机的VLAN的配置已经完成。
查看交换机VLAN配置[SW1]dis vlan
?url=http%3A%2F%2Fdingyue.ws.126.net%2F2020%2F0508%2Feea5978bp00qa08dp000hc000i900c4c.jpg
从这里可以看出,通过VLAN10的端口有Eth0/0/1和Eth0/0/5,通过VLAN20的端口有Eth0/0/2和Eth0/0/5,以此类推。

畅聊通信

回复

使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则


    Archiver|手机版|小黑屋|齐聚无忧 |网站地图

    Powered by Discuz! X3.4  © 2001-2013 Comsenz Inc.